Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Send Sheet as Attachment Email Delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jun 27, 2019 - 01:35 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jun 26, 2019 - 16:20 PDT
Update
We are continuing to investigate and will provide another update in 30 minutes.
Posted Jun 26, 2019 - 16:06 PDT
Update
We are continuing to investigate and will provide another update in 30 minutes.
Posted Jun 26, 2019 - 15:37 PDT
Investigating
We are aware of delays in receiving app-generated emails when a sheet is sent as an attachment. We are investigating and will provide an update within the next 30 minutes.
Posted Jun 26, 2019 - 15:03 PDT
This incident affected: Notifications (Email Notifications).