Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Latency
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jan 25, 2021 - 09:30 PST
Update
A fix has been implemented and our services have recovered. We will continue to monitor.
Posted Jan 25, 2021 - 08:20 PST
Update
We are continuing to investigate customer reports of increased latency when accessing the Smartsheet application. We will provide additional updates as they become available.
Posted Jan 25, 2021 - 08:05 PST
Monitoring
We have seen reports of some customers experiencing increased latency when accessing the Smartsheet application. Engineering has taken steps to mitigate and we are recovering
Posted Jan 25, 2021 - 07:27 PST
This incident affected: Core Application (Sheets, Sharing, Forms, Reports, Dashboards, Search, Mobile App, Conversations), Notifications (Email Notifications, In App Notifications), Developers and API (REST API, Webhooks), Authentication and Sign In (Smartsheet Login, Single Sign On ( Company Credentials ), Sign in via Google, Sign in via Microsoft Azure AD, Sign in via Apple ID), Documents (Attachments, Document Proofing), Workflows (In App Workflows), Administration and Audit (Admin Center, Event Reporting API, User and Group Management, Payments & Licensing, Activity Log), and Resource Management (Smartsheet Resource Views).