Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable to Save Sheets
Incident Report for Smartsheet
Postmortem

On June 10th, 2022 between 4:55 PDT and 6:39 PDT, users were unable to save changes on some of the sheets.
We addressed the issue by freeing up capacity in the sheet storage system. We are making improvements based on our learnings from the incident to avoid similar incidents in the future.

Posted Jun 10, 2022 - 16:31 PDT

Resolved
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2022 - 12:16 PDT
Update
The fix has been implemented and the issue is now resolved.
Posted Jun 10, 2022 - 12:15 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 10, 2022 - 07:30 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2022 - 06:48 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 10, 2022 - 05:56 PDT
Investigating
We are currently investigating an issue that is affecting the ability for some users to save some sheets. If you experience save failures, remain on your sheet, and try again in about 15-20 minutes. Refreshing will cause unsaved changes to be lost.
We will provide an update within the next 30 minutes.
Posted Jun 10, 2022 - 05:26 PDT
This incident affected: Core Application (Sheets).