Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Application Connectivity Issues
Incident Report for Smartsheet
Resolved
Between Monday February 4th and Wednesday February 6th, some Smartsheet customers had trouble accessing Smartsheet or experienced slow performance working with Smartsheet data.
We want to provide you an explanation of the event and the steps we have taken to prevent future occurrences.

On Monday, February 4th, we began to see increased load on our application servers. Server usage would spike and it became unable to process user requests, causing overall slowdowns for some customers.

We immediately took several actions to mitigate customer impact. In parallel, our engineers began an investigation to identify the root cause. On Wednesday morning we identified a bug in our search service that under certain conditions caused search requests to consume large amounts of memory. We immediately took action to correct this issue and our service returned to normal operations at 11 am Wednesday, February 6th.

We understand that our customers depend on Smartsheet to support their critical business needs and we take that trust very seriously. We continue to focus on providing the best experience possible with Smartsheet and appreciate the partnership of our customers.
Posted Feb 07, 2019 - 12:00 PST
Monitoring
Engineering has identified and implemented a fix to improve application performance. We will continue monitoring the performance of our user experience.
Posted Feb 06, 2019 - 10:26 PST
Update
We have reduced the number of users being impacted. Our engineering team continues investigation. Mobile application and APIs are functioning normally.
Posted Feb 06, 2019 - 09:07 PST
Update
Our engineering team continues investigation into the application issues. Some users may receive error messages when loading the application. Refreshing browser may correct the error message. Mobile application and APIs are functioning normally.
Posted Feb 06, 2019 - 08:03 PST
Update
We have reduced the number of users being impacted. Our engineering team continues investigation. Mobile application and APIs are functioning normally.
Posted Feb 05, 2019 - 18:30 PST
Update
We have reduced the number of users being impacted. Our engineering team continues investigation. Mobile application and APIs are functioning normally.
Posted Feb 05, 2019 - 16:30 PST
Update
We have reduced the number of users being impacted. Our engineering team continues investigation. Mobile application and APIs are functioning normally.
Posted Feb 05, 2019 - 15:11 PST
Update
Our engineering team continues investigation into the application issues. Some users may receive error messages when loading the application. Refreshing browser may correct the error message. Mobile application and APIs are functioning normally.
Posted Feb 05, 2019 - 12:21 PST
Update
We are continuing to investigate an issue with the web application. Some users may receive error messages when loading the application. Refreshing browser may correct the error message. Mobile and API connections are not experiencing issues.
Posted Feb 05, 2019 - 09:42 PST
Investigating
We are currently investigating an issue with the web application. Users may receive error messages when loading the application. Mobile and API connections are not experiencing issues.
Posted Feb 05, 2019 - 08:08 PST
Monitoring
Our engineering team has completed implementation. We are monitoring the platform to ensure stability.
Posted Feb 04, 2019 - 19:54 PST
Update
Our engineering team is in the process of implementing optimizations to improve performance and address latency issues reported by users earlier today.
Posted Feb 04, 2019 - 17:55 PST
Identified
Our engineering team believes to have isolated the issue and latency issues are resolving for most users. Mobile application and API remain functioning without incident.
Posted Feb 04, 2019 - 15:57 PST
Update
We continue to work to resolve performance issues that some users have reported with the Smartsheet web app. The Smartsheet mobile app and API continue to function normally.
Posted Feb 04, 2019 - 14:21 PST
Update
Our engineering team continues to investigate an intermittent issue with the application loading. Some users may receive error messages when logging into the application, form submissions and saving edits. Some form submissions and edit saves may fail.
The mobile application/API is not affected and is fully functioning.
Posted Feb 04, 2019 - 12:39 PST
Update
We are currently investigating an issue with the application loading. Users may receive error messages when loading the application and form submissions may fail.
The mobile application/API is not affected and is fully functioning.
Posted Feb 04, 2019 - 11:20 PST
Investigating
We are currently investigating an issue with the application loading. Users may see errors loading the application.
Posted Feb 04, 2019 - 11:15 PST
This incident affected: Core Application (Sheets) and Developers and API (REST API).