Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Sheets Not Loading/Opening – "Trouble Reaching Smartsheet" Error

Incident Report for Smartsheet

Update

We are continuing to monitor for any further issues.
Posted May 27, 2026 - 13:39 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 27, 2026 - 13:37 PDT

Investigating

We are currently investigating reports of sheets failing to open and displaying the error "We're having trouble reaching Smartsheet right now." Our team is actively working to resolve the issue and will provide frequent updates until we reach a monitoring status.
Posted May 27, 2026 - 10:50 PDT
This incident affects: Core Application (Sheets).