Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Investigating - Users reporting unable to add licenses or upgrade plans
Incident Report for Smartsheet
Resolved
A fix has been implemented and we are monitoring the results
Posted Mar 30, 2023 - 12:58 PDT
Update
We are continuing to investigate this issue.
Posted Mar 30, 2023 - 12:56 PDT
Investigating
We’re receiving reports from a limited number of customers indicating that they’re encountering errors when adding licenses to plans or upgrading plans.
Posted Mar 30, 2023 - 12:42 PDT
This incident affected: Administration and Audit (Payments & Licensing).