Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable To Load Reports Intermittently
Incident Report for Smartsheet
Postmortem

On April 3rd, 12:40PM PST, Smartsheet experienced a spike in load that led to high latency in our reporting features. The load returned to normal levels at by 1:17PM PST and our team performed additional fixes to prevent this problem. During this time, customers may have experienced degraded performance in accessing reports. There were no lasting customer impact beyond brief performance issues. We are making improvements based on our learnings from the incident to avoid similar issues in the future.

Posted Apr 04, 2023 - 09:34 PDT

Resolved
This incident has been resolved.
Posted Apr 03, 2023 - 14:52 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Apr 03, 2023 - 13:36 PDT
This incident affected: Premium Apps (Calendar) and Core Application (Reports, Dashboards).