Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Loading and Saving Sheets
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Nov 13, 2018 - 07:44 PST
Investigating
A small number of customers may experience issues loading and saving certain sheets. Our operations team is currently investigating the issue, and working to restore service.
Posted Nov 13, 2018 - 07:24 PST
This incident affected: Core Application (Sheets) and Developers and API (REST API).