Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Undelivered User and Group Management Reports
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Apr 13, 2019 - 09:02 PDT
Monitoring
The cause of this issue has been identified and a fix has been implemented. We are monitoring to ensure continued stability of this feature.
Posted Apr 12, 2019 - 15:36 PDT
Update
We are continuing to investigate and will provide another update in 2 hours.
Posted Apr 12, 2019 - 14:05 PDT
Update
We are continuing to investigate and will provide another update within the next 30 minutes.
Posted Apr 12, 2019 - 13:19 PDT
Update
We are continuing to investigate and will provide another update within the next 30 minutes.
Posted Apr 12, 2019 - 12:44 PDT
Update
We are continuing to investigate and will provide another update within the next 30 minutes.
Posted Apr 12, 2019 - 12:12 PDT
Investigating
We are investigating reports from system administrators not receiving User and Group Management reports. This affects the User List, Sheet Access, and Group Sheet Access reports.
We will provide an update within the next 30 minutes.
Posted Apr 12, 2019 - 11:35 PDT
This incident affected: Notifications (Email Notifications).