Smartsheet Logo
Issues with Creating Cell Links in Card View
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 16:32 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.

If you are still encountering issues with cell links, please contact Smartsheet support: https://help.smartsheet.com/contact
Posted Sep 29, 2020 - 12:37 PDT
Identified
We have identified the issue and taken action to resolve it. The service is recovering and we will continue to monitor.
Posted Sep 29, 2020 - 10:41 PDT
Update
We are continuing to investigate some customer reports of being unable to create new cell links on sheets utilizing Card View. We will provide an update in 30 minutes.
Posted Sep 29, 2020 - 10:11 PDT
Investigating
We are investigating some customer reports of being unable to create new cell links on sheets utilizing Card View. We will provide an update in 30 minutes.
Posted Sep 29, 2020 - 09:41 PDT
This incident affected: Core Application (Sheets).