Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet App Connectivity
Incident Report for Smartsheet
Postmortem

On May 28, 2024 at 9:00am PT, our Core Application in the US region experienced a deployment issue. This caused a core Smartsheet database to crash before the team could roll back that deployment. Our team immediately tried to fail over to a database replica. However, as we started bringing traffic back to the new primary database, a “retry storm” from API callers caused an increased volume of traffic; this replica database was then stressed beyond capacity and crashed. At that point, our team failed over to a second replica and started to bring the traffic back at a more suitable pace to fully restore the Smartsheet service. The US region was the only region impacted. FedGov and EMEA regions were not affected and continued to operate without customer impact.

We know how critical our services are to our customers and apologize for any impact this incident may have had on you and your business. We promise that we will do everything we can to learn from this event and use it to drive improvement across our services to ensure that Smartsheet is a partner that can be counted on to deliver. We know that your success—and your continued trust in Smartsheet—depends on it.

Posted May 29, 2024 - 11:21 PDT

Resolved
This incident has been resolved.
Posted May 28, 2024 - 19:37 PDT
Monitoring
Fixes have been implemented and we are monitoring for complete stability of our services.
Posted May 28, 2024 - 17:37 PDT
Update
We are progressively recovering our services. We will provide another update within 60 minutes.
Posted May 28, 2024 - 16:49 PDT
Update
We are progressively recovering our services. We will provide another update within 60 minutes.
Posted May 28, 2024 - 15:48 PDT
Update
We are progressively recovering our services. We will provide another update within 60 minutes.
Posted May 28, 2024 - 14:48 PDT
Identified
We are progressively recovering our services. We will provide another update within 30 minutes.
Posted May 28, 2024 - 14:18 PDT
Investigating
We're continuing to investigate Smartsheet app connectivity. We will provide an update within 30 mins.
Posted May 28, 2024 - 13:48 PDT
Update
We're continuing to investigate Smartsheet app connectivity. We will provide an update within 30 mins.
Posted May 28, 2024 - 13:18 PDT
Identified
We are continuously seeing recovery within our services as we ramp up. We will post an update within 30 mins.
Posted May 28, 2024 - 12:55 PDT
Update
We're continuing to investigate Smartsheet app connectivity. We will provide an update within 30 mins.
Posted May 28, 2024 - 12:38 PDT
Update
We're continuing to investigate Smartsheet app connectivity. We will provide an update within 30 mins.
Posted May 28, 2024 - 12:29 PDT
Update
Authentication and Sign in services have been restored. We're continuing to apply fixes on the rest of the recovery process. We will provide an update within 30 mins.
Posted May 28, 2024 - 12:10 PDT
Update
We're continuing to investigate Smartsheet app connectivity. During recovery while scaling traffic, we have experienced some issues during recovery and are investigating further. We will provide an update within 30 mins.
Posted May 28, 2024 - 12:04 PDT
Update
We're continuing to investigate Smartsheet app connectivity. During recovery while scaling traffic, we have experienced some issues during recovery and are investigating further. We will provide an update within 30 mins.
Posted May 28, 2024 - 11:37 PDT
Update
We're continuing to investigate Smartsheet app connectivity. During recovery while scaling traffic, we have experienced some issues during recovery and are investigating further. We will provide an update within 30 mins.
Posted May 28, 2024 - 11:34 PDT
Investigating
We're continuing to investigate Smartsheet app connectivity. During recovery while scaling traffic, we have experienced some issues during recovery and are investigating further. We will provide an update within 30 mins.
Posted May 28, 2024 - 11:18 PDT
Update
We're seeing recovery and users should expect improved connectivity across our services. We will post an update within 30 minutes.
Posted May 28, 2024 - 11:05 PDT
Update
For users not logged in, logins may fail, but if already logged in, sheets, reports, dashboards etc. should all be accessible and editable. We are continuing to implement a full fix for this issue. We will post an update within 30 minutes.
Posted May 28, 2024 - 10:41 PDT
Update
For users not logged in, logins may fail, but if already logged in, sheets, reports, dashboards etc. should all be accessible and editable. We are continuing to implement a full fix for this issue. We will post an update within 30 minutes.
Posted May 28, 2024 - 10:16 PDT
Identified
The issue is identified and a fix is being implemented.
Posted May 28, 2024 - 09:48 PDT
Update
We are continuing to investigate this issue.
Posted May 28, 2024 - 09:43 PDT
Investigating
We are currently investigating Smartsheet intermittent connectivity. We’ll continue providing updates every 30 minutes and will send another notification to subscribers with the next functional update.
Posted May 28, 2024 - 09:26 PDT
This incident affected: Core Application (Sheets, Sharing, Forms, Reports, Dashboards, Search, Mobile App, Conversations, Desktop App), Premium Apps (Calendar, Control Center, Datamesh, Dynamic View, Pivot, WorkApps, DataTable), Authentication and Sign In (Smartsheet Login, Single Sign On ( Company Credentials ), Sign in via Google, Sign in via Microsoft Azure AD, Sign in via Apple ID), and Resource Management (Resource Management).