Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet attachments through email
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted May 28, 2020 - 15:26 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted May 27, 2020 - 16:07 PDT
Investigating
We are investigating reports of some users experiencing issues with downloading row attachments received via email. We will provide an update within the next 30 minutes.
Posted May 27, 2020 - 16:01 PDT
This incident affected: Notifications (Email Notifications).