Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Attaching emails from Outlook
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 11:15 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.
Posted Jul 21, 2020 - 19:50 PDT
Update
We're currently verifying the fix for this issue and expect it to be deployed within the next 7 days.
Posted Jul 14, 2020 - 12:17 PDT
Update
The cause of this issue has been identified; a fix is in development and expected to be deployed within the next 7 days.
Posted Jul 07, 2020 - 11:40 PDT
Identified
We are investigating an issue of being unable to drag & drop emails from Outlook into Smartsheet. If the file is saved locally on your computer (having first drag & dropped the email onto your desktop) it can then be uploaded into Smartsheet successfully. We will provide an update as new information becomes available.
Posted Jun 29, 2020 - 13:02 PDT