Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Sheets & Dashboards Performance Issues
Incident Report for Smartsheet
Postmortem

At 9:34 AM PDT on August 8th, 2024, Smartsheet experienced a spike in backend system errors discovered via our logs. The source of the issue was related to an unusually large workload, and the system recovered on its own by 10:13 AM PDT.

Posted Aug 21, 2024 - 05:13 PDT

Resolved
This incident has been resolved.
Posted Aug 08, 2024 - 12:31 PDT
Monitoring
We have taken measures to mitigate and are monitoring the results.
Posted Aug 08, 2024 - 10:27 PDT
Investigating
We are currently investigating some customer reports of users being unable to load sheets and dashboards. We will provide an update in 30 minutes.
Posted Aug 08, 2024 - 10:00 PDT
This incident affected: Core Application (Sheets, Dashboards).