Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Report Degradation
Incident Report for Smartsheet
Resolved
The issue has been resolved.
Posted Jun 21, 2018 - 12:48 PDT
Monitoring
We have identified the issue and are monitoring it.
Posted Jun 21, 2018 - 12:40 PDT
Update
We are continuing to investigate this issue.
Posted Jun 21, 2018 - 12:31 PDT
Investigating
Our engineers are currently investigating an issue with our reporting platform. We will provide updates as the issue is identified and resolved.
Posted Jun 21, 2018 - 12:28 PDT
This incident affected: Core Application (Reports).