Postmortem
On July 15th, 2025, starting at approximately 4:54 PM PDT, some users experienced issues accessing and navigating the Smartsheet application.
Our engineering teams quickly identified the cause: a recent increase in traffic to a core service overwhelmed another critical internal service, leading to widespread service degradation.
Traffic was immediately adjusted, and the affected services were scaled to restore stability. Full service functionality was restored by approximately 5:28
Posted Jul 15, 2025 - 19:46 PDT
Resolved
This incident has been resolved.
Posted Jul 15, 2025 - 19:45 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jul 15, 2025 - 17:39 PDT
Investigating
We are currently investigating some customer reports of customers being unable to access the Smartsheet application. We will continue to provide frequent updates as we work towards resolution.
Posted Jul 15, 2025 - 17:27 PDT
This incident affected: Developers and API (REST API, Webhooks, API Access Tokens), Core Application (Smartsheet Login, Single Sign On ( Company Credentials ), Sheets, Forms, Reports, Dashboards), Documents (Attachments, Document Builder, Document Proofing, File Library), Digital Asset Management (Brandfolder) (Smartsheet Brandfolder Integration, Core Application, Asset Upload, Asset Upload - SFTP, SmartCDN, Brandguide, Integrations, Insights, Content Automation Platform, Content Automation APIs, Content Automation Rendering Services, Content Automation Templating, Content Automation Integrations), Apps (Desktop App, Mobile App), AI Tools, Search, and Third Party Sign In (Sign in via Google, Sign in via Microsoft Azure AD, Sign in via Apple ID).