Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Connectivity Issue
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 07:52 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability.
Posted Oct 29, 2019 - 12:01 PDT
Update
We have received reports of intermittent connectivity issues when accessing Smartsheet. We are actively investigating and will provide an update within the next 30 minutes.

If you receive a connectivity error message, please try re-saving or refreshing your browser.
Posted Oct 29, 2019 - 11:51 PDT
Update
We have received reports of intermittent connectivity issues when accessing Smartsheet. We are actively investigating and will provide an update within the next 30 minutes.

If you receive a connectivity error message, please try re-saving or refreshing your browser.
Posted Oct 29, 2019 - 11:22 PDT
Investigating
We have received reports of intermittent connectivity issues when accessing Smartsheet. We are actively investigating and will provide an update within the next 30 minutes.

If you receive a connectivity error message, please try re-saving or refreshing your browser.
Posted Oct 29, 2019 - 10:55 PDT