Smartsheet Logo
Intermittent 500 Errors
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 16:50 PDT
Monitoring
We are monitoring for intermittent 500 errors some Smartsheet users experienced during the timeframe of 1:20-1:30PM Pacific Time
Posted Sep 08, 2020 - 14:48 PDT