Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Reports
Incident Report for Smartsheet
Postmortem

On March 29th at 4:38am PDT, part of our Reporting service experienced a spike in the amount of large reports requests. During a period of 148 min (ending at 7:05am PDT) and again for 70min (between between 1:27pm PT and 2:37pm PT) customers may have experienced slowness when loading a report or reports failing to load altogether. 

Our team was notified by our data monitoring service of these large report requests. We isolated the issue to a dedicated stack, created to handle large report demand while promoting overall service reliability, however this stack was under provisioned. Our team calibrated the provisioning based on the demand, increasing it at around 7am PT, after which it returned to normal. The stack failed again to meet demand between 1:27pm PT and 2:37pm PT of which we re-calibrated the provisioning. Doing so allowed our service to return to normal, and has been healthy since, and we have changed our default provisioning levels to ensure this isn’t repeated. 

We continue to prioritize investments to scale our networking, compute, security, and other infrastructure, as well as our technical management processes that enable us to consistently deliver great experiences for our customers. 

We know how critical our services are to our customers and apologize for any impact this incident may have had on you and your business. We promise that we will do everything we can to learn from this event and use it to drive improvement across our services to ensure that Smartsheet is a partner that can be counted on to deliver. We know that your success—and your continued trust in Smartsheet—depends on it.

Posted Apr 17, 2024 - 09:49 PDT

Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 10:12 PDT
Monitoring
We have seen some Reports failing to load from 4:34A PDT to 7:05A PDT. A fix has been implemented and we are monitoring for continued stability of the service.
Posted Mar 29, 2024 - 09:42 PDT