Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Sharing Limits Reached when Sending emails
Incident Report for Smartsheet
Resolved
This issue has been resolved. If you receive the in-app notification, "You have exceeded the maximum number of email recipients that your account can send to," please contact Support at smartsheet.com/gethelp.
Posted Feb 25, 2019 - 16:11 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 24, 2019 - 23:51 PST
Monitoring
The ability to send emails from Smartsheet may be affected at this time due to some limitations set on collaborative sharing. We are monitoring this.
Posted Feb 24, 2019 - 23:41 PST
This incident affected: Notifications (Email Notifications).