Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Reporting Service Delay
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 28, 2018 - 12:05 PDT
Monitoring
The Reporting service is no longer experiencing delays. We are continuing to monitor this service.
Posted Jul 26, 2018 - 08:48 PDT
Investigating
Smartsheet Engineering is currently investigating a reporting delay of less than 15 minutes.
Posted Jul 26, 2018 - 07:27 PDT
This incident affected: Core Application (Reports).