Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
iOS customers unable to complete account setup after purchase
Incident Report for Smartsheet
Resolved
Our development teams have deployed a fix to resolve this issue.
Posted Mar 18, 2018 - 10:37 PDT
Identified
Customers purchasing a Smartsheet license through our iOS app are currently unable to have their signup completed. The Smartsheet Development and Quality Assurance teams have identified the bug and are currently creating and testing a solution for this issue.
Posted Mar 02, 2018 - 20:11 PST
This incident affected: Developers and API (REST API).