Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Sheet link delays
Incident Report for Smartsheet
Resolved
This issue has been resolved.
Posted Mar 19, 2019 - 06:40 PDT
Monitoring
A fix has been implemented and the backlog of sheet link updates has fully recovered. We are monitoring to ensure continued stability of this feature.
Posted Mar 18, 2019 - 19:35 PDT
Update
We are continuing to investigate delays in sheet link processing.
Posted Mar 18, 2019 - 19:11 PDT
Investigating
Sheet links processing is becoming delayed. We are investigating and will provide an update within the next 30 minutes.
Posted Mar 18, 2019 - 18:26 PDT
Monitoring
The backlog of sheet link updates has fully recovered. We are monitoring to ensure continued stability of this feature.
Posted Mar 18, 2019 - 16:59 PDT
Investigating
Our monitoring systems have detected a possible delay in sheet link updates. We are investigating and will provide an update within the next 30 minutes.
Posted Mar 18, 2019 - 16:47 PDT