This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Get email notifications whenever Smartsheet creates, updates or resolves an incident.
Get text message notifications whenever Smartsheet creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Between approximately 8:50 a.m. PST and 9:04 a.m. PST, some users experienced delays when trying to access newly created assets, such as projects, sheets, and workspaces. While these assets were created successfully, they were not immediately accessible and, in some cases, took up to 10 minutes to appear. This issue occurred due to a temporary data synchronization delay, which was fully resolved by 9:04 a.m. PST.
Posted Dec 18, 2024 - 16:42 PST
Resolved
The issue has been identified and a fix has been implemented.
Posted Dec 18, 2024 - 09:41 PST
Investigating
We are currently investigating reports that some customers are experiencing load errors with reports, sheets, and dashboards in Smartsheet. We will continue to provide frequent updates as we work towards resolution.
Posted Dec 18, 2024 - 09:30 PST
This incident affected: Core Application (Sheets, Reports, Dashboards).