Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
https://app.smartsheet.com is available. We are investigating an outage at www.smartsheet.com
Incident Report for Smartsheet
Postmortem

On June 8th, 2021 at 2:58 PDT, an issue with Fastly, a cloud service provider, caused a widespread internet outage that impacted the Smartsheet website (www.smartsheet.com) and Help Center (help.smartsheet.com), making them inaccessible or slow to load. There was no impact to the Smartsheet application or related services. At 3:57 PDT, a fix was implemented and access to the affected sites was restored. For more information about the event please visit https://status.fastly.com/.

Posted Jun 08, 2021 - 07:47 PDT

Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 06:03 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2021 - 04:03 PDT
Investigating
The www.smartsheet.com website is currently unavailable. The Smartsheet application is not impacted, and is reachable by navigating to https://app.smartsheet.com/b/home.
We are investigating this issue and will provide an update in 30 minutes.
Posted Jun 08, 2021 - 03:25 PDT
This incident affected: Help and Community (Smartsheet Website, Help Center).