Smartsheet Logo
Accessing Sheets and Reports
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 19, 2019 - 07:00 PDT
Update
We have resolved an issue that caused some customers to experience intermittent errors when accessing some sheets and reports. We will continue to monitor for 24 hours.
Posted Oct 18, 2019 - 01:23 PDT
Monitoring
We are recovering from an issue that caused some customers to experience intermittent errors when accessing some sheets and reports. We have mitigated the issue and will continue to monitor.
Posted Oct 18, 2019 - 01:06 PDT
Investigating
Investigating: Some customers experiencing issues accessing sheets and reports. We have identified the root cause and are working to mitigate the issue. Another update will be provided within 30 minutes.
Posted Oct 18, 2019 - 00:28 PDT
This incident affected: Smartsheet Application (Mobile/API, Web Application).