Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Unavailable
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 23:59 PST
Monitoring
From 2:30pm to 2:40pm Pacific, Smartsheet experienced a service interruption where users were unable to access the application. All systems are now operational
Posted Nov 13, 2019 - 15:01 PST
This incident affected: Core Application (Sheets) and Developers and API (REST API).