Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Search Functionality
Incident Report for Smartsheet
Resolved
Search has remained stable since catching up. The issue is resolved.
Posted Mar 26, 2019 - 18:00 PDT
Monitoring
We are currently seeing latency in Search results. Our Engineering team has identified the issue and taken corrective action. We are monitoring the platform for continued stability.
Posted Mar 26, 2019 - 12:11 PDT
This incident affected: Core Application (Search).