Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet intermittent connectivity
Incident Report for Smartsheet
Postmortem

On December 14, 2023 between 05:24 PM and 05:48 PM PST, users experienced a degraded experience across the Smartsheet application. The incident was caused by an incorrect service deployment that resulted in a brownout in the core application due to long running requests trying to call the service. We reverted the service deployment which restored the experience for all users.

Posted Dec 21, 2023 - 10:39 PST

Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 20:22 PST
Monitoring
A fix has been implemented and we are monitoring to ensure stability of the service.
Posted Dec 14, 2023 - 18:17 PST
Identified
We have identified the issue and taken action to resolve. The service is recovering and we will continue to monitor. We will provide an update in 30 minutes.
Posted Dec 14, 2023 - 18:00 PST
Investigating
We're investigating customer reports of Smartsheet intermittently connecting. We will provide an update within 30 mins.
Posted Dec 14, 2023 - 17:41 PST
This incident affected: Core Application (Sheets, Reports, Dashboards).