Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Issues loading assets and automations
Incident Report for Smartsheet
Postmortem

At 1:30pm PDT on July 15th, 2024, we began investigating issues with automation delays, errors while editing automations, issues with automations retriggering in quick succession, errors loading or saving certain sheets and reports, and issues with certain report widgets on dashboards. Automation delays and errors editing automations were caused by inefficient handling of workflows on deleted sheets, resulting in extensive queue length. These were resolved around 5:45pm PDT.

Issues with automations retriggering and errors loading sheets, reports, and report widgets were traced back to a misconfigured trust store that caused cell links to alternate invalid references and valid values that led to excessive cell change processing in our grid databases and latency while loading or saving sheet data. Our engineering team corrected the trust store, and normal service operation was restored on July 15th, 2024 at 6:15pm PDT.

Posted Jul 15, 2024 - 20:39 PDT

Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 20:38 PDT
Monitoring
A fix has been implemented for automation delays, errors while editing automations, issues with automations retriggering in quick succession, errors loading or saving certain sheets and reports, and issues with certain report widgets on dashboards. We are monitoring to ensure continued stability of these features.
Posted Jul 15, 2024 - 18:37 PDT
Update
We are continuing to investigate customer reports of errors while editing automations, loading sheets and reports, and viewing certain dashboard widgets. We will provide an update in 60 minutes.
Posted Jul 15, 2024 - 16:41 PDT
Investigating
We are currently investigating some customer reports of errors while editing automations, loading sheets and reports, and viewing certain dashboard widgets. We will provide an update in 60 minutes.
Posted Jul 15, 2024 - 15:28 PDT
This incident affected: Workflows (In App Workflows), Notifications (In App Notifications), and Core Application (Sheets, Reports, Dashboards).