Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Planned Maintenance
Incident Report for Smartsheet
Resolved
The maintenance is now complete.
Posted Feb 09, 2019 - 20:19 PST
Update
Beginning at 7 pm PST (Feb. 9th), there is planned maintenance activity. Some customers may experience intermittent connectivity issues accessing their sheets and reports.
We expect to have the maintenance to be completed by 10 pm PST.
Posted Feb 09, 2019 - 19:00 PST
Identified
Beginning at 7 pm PST (Feb. 9th), there is planned maintenance activity. Some customers may experience intermittent connectivity issues accessing their sheets and reports.
We expect to have the maintenance to be completed by 10 pm PST.
Posted Feb 08, 2019 - 13:09 PST
This incident affected: Core Application (Sheets) and Developers and API (REST API).