Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
App-generated emails not being received
Incident Report for Smartsheet
Resolved
RESOLVED- We have worked with third-party email security vendors to ensure that our automated emails are correctly identified as legitimate communications and have made significant improvements in deliverability.

If you believe that you are not receiving the appropriate app-generated emails, such as those generated from automated alerts, update requests, trial activation emails, and password resets, please check the settings on your email systems with the guidance of this help article:
https://help.smartsheet.com/articles/1193198-troubleshooting-guide#email, or contact Support: https://help.smartsheet.com/contact.
Posted Aug 20, 2020 - 07:04 PDT
Identified
We are working with third-party email security vendors to ensure that our automated emails are correctly identified as legitimate communications. We have made progress with these vendors and have seen significant improvements in deliverability. If you feel you are impacted by this, please check the settings on your email systems or contact support: https://help.smartsheet.com/contact. We will provide an update when more information is available.
Posted Aug 07, 2020 - 15:05 PDT
Update
We are continuing to investigate reports of app-generated emails not being received by a small number of customers. Some users have reported successful resolution by working with their IT teams to ensure that the domains listed in this help article, https://help.smartsheet.com/articles/1193198-troubleshooting-guide#email, are added to the allow list of their email spam and security systems.

If you feel you are impacted by this, please check the settings on your email systems or contact support: https://help.smartsheet.com/contact. We will provide an update when more information is available.
Posted Jul 31, 2020 - 10:29 PDT
Update
We are continuing to investigate reports of app-generated emails not being received by a small number of customers. We will provide an update when more information is available. If you feel you are impacted by this, please check the settings on your third-party email security app or contact support: https://help.smartsheet.com/contact
Posted Jul 29, 2020 - 11:15 PDT
Update
We are continuing to investigate reports of app-generated email delays.

We will provide an update within the next 60 minutes.
Posted Jul 29, 2020 - 10:03 PDT
Update
We are continuing to investigate reports of app-generated email delays.

We will provide an update within the next 30 minutes.
Posted Jul 29, 2020 - 09:32 PDT
Investigating
We are investigating some customer reports of email delivery delays of app-generated emails such as those generated from automated alerts, update requests, trial activation emails, and password resets.

We are investigating and will provide an update within the next 30 minutes.
Posted Jul 29, 2020 - 09:03 PDT
This incident affected: Notifications (Email Notifications).