Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Search Functionality
Incident Report for Smartsheet
Resolved
At 12:43 PM Pacific Standard Time (PST) on January 4, 2016 users of the Smartsheet Application would have experienced a delay in updates to Search. Our operations team responded and by 7:14 PM PST Search functionality had returned to a normal state.
Posted Jan 06, 2017 - 15:35 PST
Monitoring
The recent technical issue with Search Functionality is no longer active. We are currently monitoring the Smartsheet application to make sure everything is operating normally.
Posted Jan 04, 2017 - 22:17 PST
Investigating
We're currently experiencing some delay issues with the search functionality in Smartsheet. We're aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Jan 04, 2017 - 13:19 PST