Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet University is currently unavailable
Incident Report for Smartsheet
Postmortem

On Feb.24th at around 9AM PST, we became aware that customers were unable to access Smartsheet University. The Smartsheet application itself was unaffected. The root cause was a major outage of Skilljar, which is the provider that powers the Smartsheet University site. At around 9:20AM, Skilljar reported that their issue was resolved, and Smartsheet University came back online.

Posted Feb 25, 2022 - 09:22 PST

Resolved
This incident has been resolved.
Posted Feb 24, 2022 - 11:30 PST
Monitoring
Skilljar has reported that the issue is resolved. Smartsheet University is back online. We will continue to monitor.
Posted Feb 24, 2022 - 09:27 PST
Identified
We have received customer reports of users getting a 502 error when trying to access Smartsheet University. This is due to Skilljar service experiencing a major outage. The Smartsheet application itself is not affected.
For further details: https://status.skilljar.com/
Posted Feb 24, 2022 - 09:12 PST
This incident affected: Help and Community (Smartsheet University).