Smartsheet Logo
Cross Sheet Cell Links Not Updating
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 18:39 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.
Posted Jul 27, 2020 - 17:43 PDT
Identified
We have identified the issue with delays in cross sheet cell links updating and taken action to resolve it. The service is recovering and we will continue to monitor.
Posted Jul 27, 2020 - 14:29 PDT
Update
We are continuing to investigate customer reports of some cross sheet cell links not updating on destination sheets. We will provide an update in 30 minutes.
Posted Jul 27, 2020 - 13:55 PDT
Investigating
We are continuing to investigate customer reports of some cross sheet cell links not updating on destination sheets. We will provide an update in 30 minutes.
Posted Jul 27, 2020 - 13:21 PDT
Identified
We have identified the issue and have taken action to resolve it. The service is currently recovering and we will continue to monitor its progress.
Posted Jul 27, 2020 - 12:29 PDT
Investigating
We are currently investigating customer reports of some cross sheet cell links not updating on destination sheets. We will provide an update in 30 minutes.
Posted Jul 27, 2020 - 12:00 PDT
This incident affected: Core Application (Sheets).