Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Loading and saving sheets
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jun 04, 2020 - 15:07 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of the Smartsheet service.
Posted Jun 03, 2020 - 15:34 PDT
Investigating
We are currently investigating an issue some users are experiencing with being unable to open or save sheets, reports, and dashboards.
If you experience save failures, remain on your sheet, and try again in about 15-20 minutes. Refreshing will cause unsaved changes to be lost.
We are investigating and will provide an update within the next 30 minutes.
Posted Jun 03, 2020 - 15:28 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).