Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Delays in Sending Email
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 14:52 PST
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature. Our service is currently processing the backlog of delayed emails which we expect to complete within the next 2 hours. All new emails will send normally.
Posted Feb 23, 2021 - 12:50 PST
Investigating
We are currently investigating customer reports of delays in emails being sent from Smartsheet. Some users may experience an error message when attempting to send an email from inside the Smartsheet application. Features like Send Row may be impacted by this. Form submissions are working, however form confirmation emails will not be sent.

We will provide an update in 30 minutes.
Posted Feb 23, 2021 - 12:19 PST
This incident affected: Notifications (Email Notifications).