Smartsheet Logo
App-generated Email Delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 15:15 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of the email service.
Posted Jul 16, 2020 - 15:16 PDT
Identified
We have identified the issue and taken action to resolve it. The service is recovering and we will continue to monitor.
Posted Jul 16, 2020 - 14:45 PDT
Investigating
Our monitoring systems have detected email delivery delays of app-generated emails such as those generated from automation rules, sheets sent as an attachment, or password resets.

We are investigating and will provide an update within the next 30 minutes.
Posted Jul 16, 2020 - 14:25 PDT
This incident affected: Notifications (Email).