Smartsheet Logo

Smartsheet Status

 
 
Unable to Load Reports
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 13:48 PST
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of Reports.
Posted Dec 01, 2021 - 11:48 PST
Identified
We have identified the issue and are taking action to resolve. The service is recovering and we are continuing to monitor.
Posted Dec 01, 2021 - 11:33 PST
Investigating
We are currently investigating some customer reports of being unable to open some Reports in Smartsheet. We will provide an update in 30 minutes.
Posted Dec 01, 2021 - 10:58 PST
This incident affected: Core Application (Reports).