Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Reporting delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jun 26, 2019 - 01:41 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jun 25, 2019 - 12:00 PDT
Investigating
Our monitoring systems have detected a delay in reporting. Customers may notice stale information in reports, and stale information on dashboards if they rely on report data.
We are investigating and will provide an update within the next 30 minutes.
Posted Jun 25, 2019 - 11:24 PDT
This incident affected: Core Application (Reports).