Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Account Suspension Error Messages
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 10:09 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.
Posted Oct 09, 2020 - 08:11 PDT
Update
We are continuing to investigate.

Users can try refreshing their browsers to remove the error.
Posted Oct 09, 2020 - 07:53 PDT
Update
We are continuing to investigate. We will provide an update in 30 minutes.
Posted Oct 09, 2020 - 07:31 PDT
Update
We are continuing to investigate. We will provide an update in 30 minutes.
Posted Oct 09, 2020 - 07:04 PDT
Investigating
We are investigating customer reports of errors related to account suspension messages. We will provide an update in 30 minutes.
Posted Oct 09, 2020 - 06:30 PDT
This incident affected: Administration and Audit (Payments & Licensing).