Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Intermittent Errors in Smartsheet

Incident Report for Smartsheet

Resolved

This incident has been resolved.
Posted 5 years ago. Sep 10, 2020 - 11:42 PDT

Monitoring

A fix has been implemented and we are monitoring to ensure continued stability.
Posted 5 years ago. Sep 10, 2020 - 09:25 PDT

Identified

We have identified the issue and taken action to resolve it. The service is recovering and we will continue to monitor.
Posted 5 years ago. Sep 09, 2020 - 19:44 PDT

Update

We are continuing to investigate intermittent errors for some users in Smartsheet and will provide additional updates as they become available.
Posted 5 years ago. Sep 09, 2020 - 13:47 PDT

Update

We are continuing to investigate intermittent errors for some users in Smartsheet and will provide additional updates as they become available.
Posted 5 years ago. Sep 09, 2020 - 10:08 PDT

Investigating

We are investigating intermittent errors for some users in Smartsheet and will provide an update within the next 30 minutes.
Posted 5 years ago. Sep 09, 2020 - 09:24 PDT
This incident affected: Administration and Audit (Admin Center) and Core Application (Sheets, Forms, Reports, Dashboards).