Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Issues
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 17:20 PDT
Update
A fix has been implemented successfully and the service has recovered. We are monitoring to ensure continued stability of the Smartsheet platform.
Posted Apr 09, 2020 - 17:31 PDT
Monitoring
A fix has been implemented and services are recovering. We are monitoring to ensure continued stability of the Smartsheet platform.
Posted Apr 09, 2020 - 17:15 PDT
Update
We are continuing to investigate this issue.
Posted Apr 09, 2020 - 17:00 PDT
Investigating
We are investigating an issue with the Smartsheet platform including Forms, Reporting, and Automation Rules. We will provide an update within the next 30 minutes.
Posted Apr 09, 2020 - 16:45 PDT
This incident affected: Core Application (Sheets, Reports, Search), Notifications (Email Notifications), Developers and API (REST API), Authentication and Sign In (Single Sign On ( Company Credentials )), Resource Management (Smartsheet Resource Views), and Connectors (Jira Connector).