Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Workflow rules and Automation
Incident Report for Smartsheet
Resolved
This issue has been resolved.
Posted Feb 20, 2019 - 11:01 PST
Monitoring
We've identified the cause of this issue and have implemented a fix. Delays in notifications and workflow rules are processing with up to a 45 minute delay and are recovering quickly. We are monitoring to ensure continued stability of this feature.
Posted Feb 20, 2019 - 10:08 PST
Update
We are continuing to investigate delays in automated notifications and workflow rules. Some users may also experience issues creating or modifying workflow rules.
Posted Feb 20, 2019 - 09:26 PST
Investigating
Our monitoring systems has detected a possible delay in notifications and workflow rules. Some customers could experience up to an hour delay at this time. We will provide an update within the next 30 minutes.
Posted Feb 20, 2019 - 08:56 PST
This incident affected: Core Application (Sheets).