Smartsheet Logo
Collaboration Service Delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 15:15 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Mar 17, 2020 - 15:13 PDT
Investigating
We are investigating delays in three areas of our Collaboration service: Active Refresh, sharing notifications, and refresh prompts. We will provide an update in the next 30 minutes.
Posted Mar 17, 2020 - 14:52 PDT