Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Application Slowness
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 26, 2022 - 15:25 PDT
Monitoring
Our engineering team has implemented a fix and we are continuing to monitor to ensure the continued stability of the service.
Posted Jul 26, 2022 - 13:23 PDT
Identified
We have identified an issue that is currently causing intermittent web app slowness and connectivity issues. Our engineering team is currently pursuing a fix for this behavior.
Posted Jul 26, 2022 - 11:31 PDT
This incident affected: Core Application (Sheets, Forms, Reports, Dashboards, Search).