Smartsheet Logo

Smartsheet Status

 
 
Reports Intermittently Loading
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 13, 2021 - 11:47 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Sep 13, 2021 - 09:46 PDT
Update
We are continuing to investigate some customer reports with being unable to open Reports in Smartsheet. Other users may be able to use Reports without issue. We will provide an update in 30 minutes.
Posted Sep 13, 2021 - 09:39 PDT
Investigating
We are currently investigating some customer reports of being unable to open some Reports in Smartsheet. We will provide an update in 30 minutes.
Posted Sep 13, 2021 - 09:05 PDT
This incident affected: Core Application (Reports, Dashboards).