Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Regional intermittent slow loading
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Aug 31, 2022 - 08:51 PDT
Monitoring
We’re monitoring some customer reports from Australia and New Zealand regions with intermittent networking issues between their ISPs and US-based web applications. If you’re experiencing these issues, please contact your ISP to investigate.
Posted Aug 23, 2022 - 20:12 PDT
This incident affected: Authentication and Sign In (Smartsheet Login, Single Sign On ( Company Credentials ), Sign in via Google, Sign in via Microsoft Azure AD, Sign in via Apple ID).