Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Informational Update
Incident Report for Smartsheet
Resolved
This morning at 6:30 AM PDT, Smartsheet's Customer Support team reported issues of customers in eastern regions of the United States experiencing timeouts and errors while attempting to load the Smartsheet Application. Operations engaged and did a review of Smartsheet systems and network status. It was determined that the event was external to the Smartsheet Application and infrastructure.
Posted Aug 02, 2017 - 13:48 PDT
Monitoring
After reviewing our systems and networks, we've identified the issue as an external network event and not a problem with the Smartsheet Application. We are continuing to monitor the situation at this time.
Posted Aug 02, 2017 - 10:22 PDT
Investigating
We are receiving reports of users in the eastern region of the United States experiencing timeouts or issues connecting to the Smartsheet application. We are investigating the issue. Thanks for your patience.
Posted Aug 02, 2017 - 07:35 PDT
This incident affected: Core Application (Sheets).