Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Degraded attachment performance
Incident Report for Smartsheet
Postmortem

On March 22, 2024 at 8:45 AM PDT, customers reported issues opening attachments on rows and comments. Following investigation, the engineering team discovered a deployment that introduced the issue and were able to roll back that deployment.

Our engineers were able to restore the ability to open attachments and rows and comments at 10:00 AM PDT. The team continued monitoring the affected feature for function and performance until 12:00 PDT, no new customer issues were reported.

Posted Mar 22, 2024 - 12:00 PDT

Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 11:59 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2024 - 10:00 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 22, 2024 - 09:40 PDT
Investigating
We are currently investigating some customer reports of issues accessing and opening attachments. We will provide an update in 60 minutes.
Posted Mar 22, 2024 - 09:04 PDT
This incident affected: Documents (Attachments).